FB175E: Issues with outgoing transactions, web console access and API due to Cloudflare outage

Incident Report for Fireblocks Europe

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:11 UTC

Identified

We are currently encountering issues with our transaction processing engine and web console access due to Cloudflare outage: https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 08:56 UTC
This incident affected: Web console, API, and Transactions engine.